転載・引用について

ユーザ用ツール

サイト用ツール


サイドバー

Site Contents Index

転載・引用について

RSS

tweet:2018:0622_01

CEoRとpSST

正直なところ、gitが好きなわけではない(というより、svnでいいじゃん。局面によってはcvsでもrcsでもいいと思っている)が、まぁ、色々あって、GitHUBに

  • CEoR Command Executer on Remote
  • pSST personal Shell Script Tools

を公開した。

システム管理支援のためのScriptなので、基本はPOSIXに閉じたいという考えはある。 (完全に閉じることは不可能だが、ツール自体は閉じたい)

POSIXに閉じたい理由は、「多くのUNIX系システムであれば、POSIX準拠していればInstall baseの段階で利用できる 可能性が高い 」からである。

  1. 結局初期段階であれもいれてこれもいれて、
  2. そんでこうしないとリモートから管理できない

などというのは、運用上は辛いことだし、入れたツールがDis-Continuedになってしまえば、その後の対応で辛い思いをすることは自明。

Python2系と3系で互換性がなくなったため、今はまだ色々面倒な思いをしているわけだしそのような事態は別にPythonに限らず、昔PHPにもあったし、Rubyにもあった。

まぁ、POSIXだから大丈夫というつもりはないが、今のところもっともConcreteでかつ普及しているのがPOSIXだから、それを使えばいいか、くらいの考え。

興味ある人は少ないだろうな(笑)

このウェブサイトはクッキーを使用しています。 Webサイトを使用することで、あなたはあなたのコンピュータにクッキーを保存することに同意します。 また、あなたはあなたが私たちのプライバシーポリシーを読んで理解したことを認めます。 同意しない場合はウェブサイトを離れてください。クッキーに関する詳細情報
tweet/2018/0622_01.txt · 最終更新: 2018/06/22 12:05 (外部編集)